Debugging ToolbarItemInterface

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Debugging ToolbarItemInterface

Matt Clough-2
Hi All,

I am trying to create a new toolbar item in the backend of Typo3 to appear next to user toolbar at the top of the screen. This toolbar implements TYPO3\CMS\Backend\Toolbar\ToolbarItemInterface. I can get it to display some simple content, but i am unable to debug any logic i put into it. I get no output in any of the function with \TYPO3\CMS\Extbase\Utility\DebuggerUtility::var_dump();

I am using the latest 8.7 release

Any help would be most appreciated.

Thanks

Matt
_______________________________________________
TYPO3-english mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Debugging ToolbarItemInterface

Florian Rival-3
Hi Matt,

If you want to debug the BE, you have to use debug() instead or var_dump() :

\TYPO3\CMS\Core\Utility\DebugUtility::debug($or, 'or');

Florian
--
-- Florian Rival --
www.oktopuce.fr
_______________________________________________
TYPO3-english mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Debugging ToolbarItemInterface

Matt Clough-2
Just tried  \TYPO3\CMS\Core\Utility\DebugUtility::debug and still no output on the screen or in the debug console.

This does make developing this toolbar item much more difficult without an easy way to see what is going on.

Thanks

Matt
_______________________________________________
TYPO3-english mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
Loading...