Diverse Updateprobleme

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Diverse Updateprobleme

Christoph
Hallo Zusammen,

ich habe ein Update von TPYO3 8 auf 9 durchgeführt. Vorgehen: alle
Extensions deaktiviert, Update durchgeführt (Tabellen der deaktivierten
Erweiterungen hab ich nicht angefasst), Extensions geupdatet und wieder
aktiviert. Erwähnenswerte Erweiterungen: Gridelements

Jetzt habe ich folgende Probleme:

1.) ALLE vorher in Gridelements befindlichen Elemente haben die
Verknüpfung zu den dazugehörigen Gridelements verloren und werden als
normale Inhalte angezeigt.

2.) Wenn ich ein solches Element bearbeiten will (Elementeigenschaften),
dann begrüsst mit eine Fehlermeldung (vgl. Anhang)

3.) Ich hatte Inhalte in den Spalten links/rechts. Die gibt es ja
erstmal nicht in TYPO3 9. Jetzt habe ich ein Backendlayou angelegt und
die dreispaltige Darstellung wieder hergestellt, bis auf die Inhalte der
Spalte "Normal" bleiben die anderen Inhalte aber "unused elements". Die
"unused elements" haben "-2" als Spaltenwert. Meine Idee wäre, das jetzt
über die Datenbank (suchen & ersetzen: "-2" -> "2") zu lösen. Gibt es
hier einen besseren Weg?

Hat jemand prinzipiell Ideen? Ist meine Updateansatz ggf. falsch bzw.
sollte ich anders vorgehen?

Danke Euch!

VG
Christoph



_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: Diverse Updateprobleme

Birgit
Hallo Christoph,

das passiert immer beim TYPO3 Update, wenn gridelements installiert ist.
Das liegt daran, dass gridelements für colPos negative Werte setzt, die beim TYPO3 Updatevorgang elimininiert werden.
Dann sind die Inhalte der Gridelemente nicht mehr zuordenbar.

Ich mache das so:

Vor dem TYPO3 Update:

ALTER TABLE tt_content
ADD COLUMN colPos_grid smallint(6) NOT NULL DEFAULT '0'  AFTER colPos

UPDATE tt_content
SET colPos_grid = colPos

Nach dem TYPO3 Update:

ALTER TABLE tt_content
CHANGE colPos colPos smallint(6) NOT NULL default ‚0'

UPDATE tt_content
SET colPos = colPos_grid


Viele Grüße Birgit




> Am 25.02.2020 um 09:15 schrieb Christoph <[hidden email]>:
>
> Hallo Zusammen,
>
> ich habe ein Update von TPYO3 8 auf 9 durchgeführt. Vorgehen: alle
> Extensions deaktiviert, Update durchgeführt (Tabellen der deaktivierten
> Erweiterungen hab ich nicht angefasst), Extensions geupdatet und wieder
> aktiviert. Erwähnenswerte Erweiterungen: Gridelements
>
> Jetzt habe ich folgende Probleme:
>
> 1.) ALLE vorher in Gridelements befindlichen Elemente haben die
> Verknüpfung zu den dazugehörigen Gridelements verloren und werden als
> normale Inhalte angezeigt.
>
> 2.) Wenn ich ein solches Element bearbeiten will (Elementeigenschaften),
> dann begrüsst mit eine Fehlermeldung (vgl. Anhang)
>
> 3.) Ich hatte Inhalte in den Spalten links/rechts. Die gibt es ja
> erstmal nicht in TYPO3 9. Jetzt habe ich ein Backendlayou angelegt und
> die dreispaltige Darstellung wieder hergestellt, bis auf die Inhalte der
> Spalte "Normal" bleiben die anderen Inhalte aber "unused elements". Die
> "unused elements" haben "-2" als Spaltenwert. Meine Idee wäre, das jetzt
> über die Datenbank (suchen & ersetzen: "-2" -> "2") zu lösen. Gibt es
> hier einen besseren Weg?
>
> Hat jemand prinzipiell Ideen? Ist meine Updateansatz ggf. falsch bzw.
> sollte ich anders vorgehen?
>
> Danke Euch!
>
> VG
> Christoph
>
>
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: Diverse Updateprobleme

Christoph
Hallo Birgit,

vielen vielen Dank für den Tipp! Das hat super geklappt  :-)

zu Problem 3: ich habe jetzt vor dem Update schon ein Backendlayout
angelegt, das hat auch dieses Problem gelöst.

VG
Christoph

Am 25.02.2020 um 09:29 schrieb Birgit:

> Hallo Christoph,
>
> das passiert immer beim TYPO3 Update, wenn gridelements installiert ist.
> Das liegt daran, dass gridelements für colPos negative Werte setzt, die beim TYPO3 Updatevorgang elimininiert werden.
> Dann sind die Inhalte der Gridelemente nicht mehr zuordenbar.
>
> Ich mache das so:
>
> Vor dem TYPO3 Update:
>
> ALTER TABLE tt_content
> ADD COLUMN colPos_grid smallint(6) NOT NULL DEFAULT '0'  AFTER colPos
>
> UPDATE tt_content
> SET colPos_grid = colPos
>
> Nach dem TYPO3 Update:
>
> ALTER TABLE tt_content
> CHANGE colPos colPos smallint(6) NOT NULL default ‚0'
>
> UPDATE tt_content
> SET colPos = colPos_grid
>
>
> Viele Grüße Birgit
>
>
>
>
>> Am 25.02.2020 um 09:15 schrieb Christoph <[hidden email]>:
>>
>> Hallo Zusammen,
>>
>> ich habe ein Update von TPYO3 8 auf 9 durchgeführt. Vorgehen: alle
>> Extensions deaktiviert, Update durchgeführt (Tabellen der deaktivierten
>> Erweiterungen hab ich nicht angefasst), Extensions geupdatet und wieder
>> aktiviert. Erwähnenswerte Erweiterungen: Gridelements
>>
>> Jetzt habe ich folgende Probleme:
>>
>> 1.) ALLE vorher in Gridelements befindlichen Elemente haben die
>> Verknüpfung zu den dazugehörigen Gridelements verloren und werden als
>> normale Inhalte angezeigt.
>>
>> 2.) Wenn ich ein solches Element bearbeiten will (Elementeigenschaften),
>> dann begrüsst mit eine Fehlermeldung (vgl. Anhang)
>>
>> 3.) Ich hatte Inhalte in den Spalten links/rechts. Die gibt es ja
>> erstmal nicht in TYPO3 9. Jetzt habe ich ein Backendlayou angelegt und
>> die dreispaltige Darstellung wieder hergestellt, bis auf die Inhalte der
>> Spalte "Normal" bleiben die anderen Inhalte aber "unused elements". Die
>> "unused elements" haben "-2" als Spaltenwert. Meine Idee wäre, das jetzt
>> über die Datenbank (suchen & ersetzen: "-2" -> "2") zu lösen. Gibt es
>> hier einen besseren Weg?
>>
>> Hat jemand prinzipiell Ideen? Ist meine Updateansatz ggf. falsch bzw.
>> sollte ich anders vorgehen?
>>
>> Danke Euch!
>>
>> VG
>> Christoph
>>
>>
>> _______________________________________________
>> TYPO3-german mailing list
>> [hidden email]
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german


_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: Diverse Updateprobleme

Marcus Raphelt-3
In reply to this post by Birgit
Hallo zusammen,

wenn man Gridelements während des Update-Vorganges installiert lässt,
behält der Updater den Wert bei. Die u.a. Vorgehensweise klappt
natürlich trotzdem.

Gruß
Marcus

Am 25.02.20 um 09:29 schrieb Birgit:

> Hallo Christoph,
>
> das passiert immer beim TYPO3 Update, wenn gridelements installiert ist.
> Das liegt daran, dass gridelements für colPos negative Werte setzt,
> die beim TYPO3 Updatevorgang elimininiert werden.
> Dann sind die Inhalte der Gridelemente nicht mehr zuordenbar.
>
> Ich mache das so:
>
> Vor dem TYPO3 Update:
>
> ALTER TABLE tt_content
> ADD COLUMN colPos_grid smallint(6) NOT NULL DEFAULT '0'  AFTER colPos
>
> UPDATE tt_content
> SET colPos_grid = colPos
>
> Nach dem TYPO3 Update:
>
> ALTER TABLE tt_content
> CHANGE colPos colPos smallint(6) NOT NULL default ‚0'
>
> UPDATE tt_content
> SET colPos = colPos_grid
>
>
> Viele Grüße Birgit
>
>

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german