Re: TYPO3-german Digest, Vol 34, Issue 16

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: TYPO3-german Digest, Vol 34, Issue 16

Christian Wolfram

-----Ursprüngliche Nachricht-----
Von: [hidden email]
[mailto:[hidden email]] Im Auftrag von
[hidden email]
Gesendet: Donnerstag, 6. Juli 2006 07:05
An: [hidden email]
Betreff: TYPO3-german Digest, Vol 34, Issue 16

Send TYPO3-german mailing list submissions to
        [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german
or, via email, send a message with subject or body 'help' to
        [hidden email]

You can reach the person managing the list at
        [hidden email]

When replying, please edit your Subject line so it is more specific than
"Re: Contents of TYPO3-german digest..."


Today's Topics:

   1. Re: RealURL zum Vergessen von Seitennamen bringen?
      (Tolleiv Nietsch)
   2. Re: bahag_photogallery (Andreas Gawelczyk)
   3. Re: RealURL zum Vergessen von Seitennamen bringen? (Achim Baur)
   4. 503 Error bei W3C-Validation-Service (Sebastian Meyer)
   5. Re: Typo3 offline entwickeln (Michael Meurer)
   6. Re: tt_news 2.4.0 erweitern mit "itemMarkerArrayFunc.php"
      (Tim Zech)
   7.  Toplinks trotz <base> (Andri Hdnsel)
   8. Re: 503 Error bei W3C-Validation-Service (Thomas Herok)
   9.  Probleme nach Umzug offline -> Server (Achim Marliani)
  10. Re: Backup (Robert Fink)
  11. Reihenfolge der Felder im Backend ?ndern (Nicolas Leuenberger)
  12. Re: tt_news 2.4.0 erweitern mit "itemMarkerArrayFunc.php"
      (Burkhardt Wenzel)


----------------------------------------------------------------------

Message: 1
Date: Wed, 05 Jul 2006 19:22:25 +0200
From: Tolleiv Nietsch <[hidden email]>
Subject: Re: [TYPO3-german] RealURL zum Vergessen von Seitennamen
        bringen?
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed

Achim Baur schrieb:

> kann man RealURL wirklich nicht dazu bringen, alte Seitentitel zu
> "vergessen" und den neuen Namen der Seite zu ?bernehmen?


Hallo, da hast du was falsch verstanden - da steht ja nur das diese Seiten
erstmal nur ?ber die alte URL weitergef?hrt werden - das kannst du aber
?ndern ?ber Web>Info>Speaking URL Management und da kannste alles m?gliche
zum Thema einstellen

Zu bedenken ist nat?rlich das man eine einmal bei einer SuMa gelistete URL
nicht einfach ins Nirvana schicken sollte...

Gru? Tolleiv


------------------------------

Message: 2
Date: Wed, 05 Jul 2006 19:51:34 +0200
From: Andreas Gawelczyk <[hidden email]>
Subject: Re: [TYPO3-german] bahag_photogallery
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed

wei? jemand ob bahag_photogallery auch mit IM 4.2.9 funktioniert?

Hallo Andreas,

Die bahag_photohallery funktioniert erst ab IM 6.2.x. Hatte das gleiche
Problem, jedoch hatte mein Provider bereits umgestellt gehabt und seid dem
läuft alles super. Auch die negativen Kritiken der Gallery, dass es zu lange
dauert die Bilder zu generieren, kann ich bisher nicht nach vollziehen.

Mit freundlichen Grüßen
Christian


------------------------------

Message: 3
Date: Wed, 05 Jul 2006 20:03:55 +0200
From: Achim Baur <[hidden email]>
Subject: Re: [TYPO3-german] RealURL zum Vergessen von Seitennamen
        bringen?
To: German Typo3 Userlist <[hidden email]>
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed

Ah, das habe ich gesucht. Danke!

Tolleiv Nietsch schrieb:

> Achim Baur schrieb:
>
>  
>> kann man RealURL wirklich nicht dazu bringen, alte Seitentitel zu
>> "vergessen" und den neuen Namen der Seite zu ?bernehmen?
>>    
>
>
> Hallo, da hast du was falsch verstanden - da steht ja nur das diese
> Seiten erstmal nur ?ber die alte URL weitergef?hrt werden - das kannst
> du aber ?ndern ?ber Web>Info>Speaking URL Management und da kannste
> alles m?gliche zum Thema einstellen
>
> Zu bedenken ist nat?rlich das man eine einmal bei einer SuMa gelistete
> URL nicht einfach ins Nirvana schicken sollte...
>
> Gru? Tolleiv
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german
>
>
>  



------------------------------

Message: 4
Date: Wed, 05 Jul 2006 20:18:50 +0200
From: Sebastian Meyer <[hidden email]>
Subject: [TYPO3-german] 503 Error bei W3C-Validation-Service
To: TYPO3 Deutsch <[hidden email]>
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hallo Liste!

Gerade wollte ich die Validate-Checks des W3-Konsortiums f?r eine neue
Webseite durchf?hren, aber s?mtliche Checks liefern nur einen 503-Fehler
zur?ck, wenn sie versuchen, die Seite zu parsen. (Service temporarily
unavailable.)
Ich habe es sowohl mit dem XHTML-, als auch mit dem CSS- und WCAG-Check
versucht - immer dasselbe Ergebnis.

Frage: K?nnte das an Typo3 liegen? Ich verwende Version 4.0 mit RealURL.

Gru? und so,
Sebastian



------------------------------

Message: 5
Date: Wed, 05 Jul 2006 20:22:07 +0200
From: Michael Meurer <[hidden email]>
Subject: Re: [TYPO3-german] Typo3 offline entwickeln
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hallo zusammen.

Sorry, Meik, ich kann dein Problem mit den Pfadangaben nicht so recht
nachvollziehen, vielleicht liegt das aber auch an meinem Heuschnupfen...

Ich entwickle meine Seiten auch erst lokal, wohl aber auf einem zweiten
Recher.
Vielleicht hilft dir das hier:

Im config-Bereich meines Projektes steht baseURL =
http://lokale_ip/ordnername/ Die Bilder sind in einem Ordner innerhalb des
Projektes. Habe keine Probleme mit den Bildern.
Sobald ich die Seite hochlade, die DB importiere und die baseURL in baseURL
= http://domain.ltd/ordnername/ ?ndere, passt das immer noch mit den
Bildern.

Was die statischen Seiten angeht:
Vielleicht w?re es ein Aspekt, die statischen Seiten als Contentelement mit
einem URL-Grabber einzubinden und nach und nach zu portieren.

Die Ext wag_urlgrab und evtl. fetchurl k?nnen u. a. eine lokale Html-Datei
einlesen.


Gru? Michael


------------------------------

Message: 6
Date: Wed, 5 Jul 2006 20:32:35 +0200
From: "Tim Zech" <[hidden email]>
Subject: Re: [TYPO3-german] tt_news 2.4.0 erweitern mit
        "itemMarkerArrayFunc.php"
To: "German Typo3 Userlist" <[hidden email]>
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=UTF-8; format=flowed

hast du mal einfach ein echo gemacht, um zu sehen, dass deine funktion
angesprochen wird?

2006/7/5, Burkhardt Wenzel <[hidden email]>:

> hallo liebe liste,
>
> mir qualmt echt der kopf und bin mit meinem latein am ende:
>
> laut manual habe ich versucht tt_news um ein eigenes feld
> zu erweitern. daf?r habe ich mit dem kickstarter eine eigene extension
> erstellt. prima: das neue feld(zus?tzlicher rte) ist auch im backend
> da und l?sst sich mit inhalten f?llen.
>
> dann nat?rlich noch das rendern des content f?r das frontend:
> daf?r habe ich laut manual die userfunction "itemMarkerArrayFunc"
> benutzt.
> leider wird der marker nicht erkannt und ergo auch kein content
> ausgegeben. ich dachte die funktion sei genau daf?r gut eigene marker
> f?r zus?tzliche felder zu benutzen. habe ich da was falsch verstanden?
>
> mein setup:
>
> #allgemeines
> ################################################################
> neue erzeugtes feld tt_news: tx_xmnews_special
> field name in der extension: special
> template-marker: ###NEWS_SPECIAL###
>
> #ts in root template
> ################################################################
> # include php script for extended news
> includeLibs.displayExtendedNews =EXT:xm_news/res/itemMarkerArrayFunc.php
> # call user function
> plugin.tt_news.itemMarkerArrayFunc = user_displayExtendedNews
>
>
> #itemMarkerArrayFunc.php
> ################################################################
> <?php
> function user_displayExtendedNews($markerArray, $conf){
>         $row = $conf['parentObj']->local_cObj->data; // get the data array
of
> the current news record
>                 if ($row['tx_xmnews_special']) {
>                         $markerArray['###NEWS_SPECIAL###'] .=
>
$conf['parentObj']->local_cObj->tx_xmnews_special($conf['parentObj']->conf['

> tx_xmnews_special.']) ;
>
>                 } else { // No content in  field special
>                 $markerArray['###NEWS_SPECIAL###']='Test ';
>         }
>         return $markerArray;
> }
>
> ?>
>
> wie genau kann ich denn den marker ansprechen und wie genau
> kann ich den content f?r mein zus?tzliches feld ausgeben?
>
>
> bin f?r jeden tipp extrem dankbar!
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german
>

------------------------------

Message: 7
Date: Wed, 5 Jul 2006 20:42:47 +0200
From: "Andri Hdnsel" <[hidden email]>
Subject: [TYPO3-german]  Toplinks trotz <base>
To: [hidden email]
Message-ID:
        <[hidden email]>

Hi,

ich benutze RealURL und somit auch <base href="...">.

Wenn ich nun einen Toplink machen mvchte, kann ich nicht mehr <a href="#">
schreiben, denn das bezieht sich ja dann aufs Stammverzeichnis.

Wie mache ich das am elegantesten?

Gr|_e,
Andri




------------------------------

Message: 8
Date: Wed, 05 Jul 2006 20:59:28 +0200
From: Thomas Herok <[hidden email]>
Subject: Re: [TYPO3-german] 503 Error bei W3C-Validation-Service
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-1

Sebastian Meyer wrote:

> Hallo Liste!
>
> Gerade wollte ich die Validate-Checks des W3-Konsortiums f?r eine neue
> Webseite durchf?hren, aber s?mtliche Checks liefern nur einen 503-Fehler
> zur?ck, wenn sie versuchen, die Seite zu parsen. (Service temporarily
> unavailable.)
> Ich habe es sowohl mit dem XHTML-, als auch mit dem CSS- und WCAG-Check
> versucht - immer dasselbe Ergebnis.
>
> Frage: K?nnte das an Typo3 liegen? Ich verwende Version 4.0 mit RealURL.

Manchmal klappt es und manchmal nicht, das ist die Erfahrung die ich
machen konnte. Mein simpler Workaround daf?r ist (in Firefox):

Seite aufrufen
Strg + u (Quelltext anzeigen)
Strg + a (Quelltext markieren)
Strg + c (Quelltext in die Zwischenablage kopieren)
W3C Seite aufrufen und Eingabefeld unten anklicken "Validate by Direct
Input"
Strg + v (Quelltext aus der Zwischenablage rauskopieren)
Enter

Viel Spass damit
Gru? Thomas


------------------------------

Message: 9
Date: Wed, 05 Jul 2006 22:18:39 +0200
From: Achim Marliani <[hidden email]>
Subject: [TYPO3-german]  Probleme nach Umzug offline -> Server
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed

Hallo alle,

ich hab ein dummes Anf?ngerproblem: Ich hab den gr??ten Teil meines
geplanten Typo3-Auftrittes offline entwickelt. Klappte auch alles prima.
Dann hab ich alles auf den echten WWW-Server ?bertragen. Ergebnis: das
Backend klappt problemlos und zeigt auch alle Inhalte, nur das Frontend
und die Vorschau aus dem Backend heraus bleiben v?llig wei?. Nicht mal
ne Fehlermeldung kommt. Was l?uft denn da schief?

R?tselnd
Achim


------------------------------

Message: 10
Date: Thu, 6 Jul 2006 0:04:14 +0200
From: Robert Fink <[hidden email]>
Subject: Re: [TYPO3-german] Backup
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=iso-8859-1

Moin!

> ja - und die erweiterung macht das auch gut, aber nur von Hand, oder
> ?bersehe ich was?
> sch?n w?re, man k?nnte sie ?ber einen cronjob starten


mysqldump ... lalala | gzip
tar cfz blubb.tgz lala
rsync lalala

Sowas halt.

                        -r



------------------------------

Message: 11
Date: Thu, 06 Jul 2006 00:36:34 +0200
From: Nicolas Leuenberger <[hidden email]>
Subject: [TYPO3-german] Reihenfolge der Felder im Backend ?ndern
To: German Typo3 Userlist <[hidden email]>
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Habe mittels Kickstarter eine Extension geschrieben, welche fe_users um
zwei Felder erweitert. Diese erscheinen im Backend nun ganz zuunterst.
Kann ich die Reihenfolge, in der die Felder gelistet werden, irgendwie
ver?ndern? Einige der Standard-Felder sind mir nicht wichtig, die m?cht
ich zuunterst, und die neuen daf?r weiter oben. Geht das?

Gr?sse
Nico
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german
>
>
>  


------------------------------

Message: 12
Date: Thu, 06 Jul 2006 07:04:53 +0200
From: Burkhardt Wenzel <[hidden email]>
Subject: Re: [TYPO3-german] tt_news 2.4.0 erweitern mit
        "itemMarkerArrayFunc.php"
To: [hidden email]
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset=UTF-8; format=flowed

ja habe ich gemacht, ganz b?se: offensichtlich
wird noch nicht einmal die funktion erkannt; grmpf

so stehts aber im manual bzw. ist das die modifizierte
version von tt_news/res/example_itemMarkerArrayFunc.php

damit soll man auf die funktion itemMarkerArrayFunc()
zugreifen k?nnen, die eine class von tt_news ist.




Tim Zech schrieb:

> hast du mal einfach ein echo gemacht, um zu sehen, dass deine funktion
> angesprochen wird?
>
> 2006/7/5, Burkhardt Wenzel <[hidden email]>:
>> hallo liebe liste,
>>
>> mir qualmt echt der kopf und bin mit meinem latein am ende:
>>
>> laut manual habe ich versucht tt_news um ein eigenes feld
>> zu erweitern. daf?r habe ich mit dem kickstarter eine eigene extension
>> erstellt. prima: das neue feld(zus?tzlicher rte) ist auch im backend
>> da und l?sst sich mit inhalten f?llen.
>>
>> dann nat?rlich noch das rendern des content f?r das frontend:
>> daf?r habe ich laut manual die userfunction "itemMarkerArrayFunc"
>> benutzt.
>> leider wird der marker nicht erkannt und ergo auch kein content
>> ausgegeben. ich dachte die funktion sei genau daf?r gut eigene marker
>> f?r zus?tzliche felder zu benutzen. habe ich da was falsch verstanden?
>>
>> mein setup:
>>
>> #allgemeines
>> ################################################################
>> neue erzeugtes feld tt_news: tx_xmnews_special
>> field name in der extension: special
>> template-marker: ###NEWS_SPECIAL###
>>
>> #ts in root template
>> ################################################################
>> # include php script for extended news
>> includeLibs.displayExtendedNews =EXT:xm_news/res/itemMarkerArrayFunc.php
>> # call user function
>> plugin.tt_news.itemMarkerArrayFunc = user_displayExtendedNews
>>
>>
>> #itemMarkerArrayFunc.php
>> ################################################################
>> <?php
>> function user_displayExtendedNews($markerArray, $conf){
>>         $row = $conf['parentObj']->local_cObj->data; // get the data
>> array of
>> the current news record
>>                 if ($row['tx_xmnews_special']) {
>>                         $markerArray['###NEWS_SPECIAL###'] .=
>>
$conf['parentObj']->local_cObj->tx_xmnews_special($conf['parentObj']->conf['

>>
>> tx_xmnews_special.']) ;
>>
>>                 } else { // No content in  field special
>>                 $markerArray['###NEWS_SPECIAL###']='Test ';
>>         }
>>         return $markerArray;
>> }
>>
>> ?>
>>
>> wie genau kann ich denn den marker ansprechen und wie genau
>> kann ich den content f?r mein zus?tzliches feld ausgeben?
>>
>>
>> bin f?r jeden tipp extrem dankbar!
>> _______________________________________________
>> TYPO3-german mailing list
>> [hidden email]
>> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german
>>


------------------------------

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german

End of TYPO3-german Digest, Vol 34, Issue 16
********************************************

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-german