tx_news / Routing

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

tx_news / Routing

Christoph
Hallo Zusammen,

nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
schöne URLs zu generieren.

Dazu nutze ich den unter
https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
zu findenden Code.

Heraus kommt folgendes:

/artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572

Das "page-0" kommt von der genannten Konfig.

Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
doch für die News an sich will es nicht klappen...

Hat jemand eine Idee??

Danke!
VG & schon mal ein schönes Wochenende

Christoph


_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: tx_news / Routing

Birgit
Hallo Christoph,

kann es sein, dass in deinem YAML eine Einrückung verrutscht ist?
YAML ist das sehr „empfindlich“.

Das page-0 bekommst du weg, mit dem Setzen von
defaults:
      page: '0'


viele Grüße Birgit

> Am 28.02.2020 um 14:28 schrieb Christoph <[hidden email]>:
>
> Hallo Zusammen,
>
> nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
> schöne URLs zu generieren.
>
> Dazu nutze ich den unter
> https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
> zu findenden Code.
>
> Heraus kommt folgendes:
>
> /artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572
>
> Das "page-0" kommt von der genannten Konfig.
>
> Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
> doch für die News an sich will es nicht klappen...
>
> Hat jemand eine Idee??
>
> Danke!
> VG & schon mal ein schönes Wochenende
>
> Christoph
>
>
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: tx_news / Routing

Christoph
Hallo Birgit,

danke für Deine Antwort!

Ich bin mir sicher, dass ich die Einrückungen richtig habe, sonst würde
ja auch der part mit "page-0" und die korrekten Tag-Links nicht erzeugt
werden.
Unten mal mein Versuch. Ggf. findet noch jemand den Fehler?!
Danke!
VG
Christoph

routeEnhancers:
  News:
    type: Extbase
    limitToPages: [37,1485,136,1486]
    extension: News
    plugin: Pi1
    routes:
      - routePath: '/'
        _controller: 'News::list'
      - routePath: '/page-{page}'
        _controller: 'News::list'
        _arguments:
          page: '@widget_0/currentPage'
      - routePath: '/{news-title}'
        _controller: 'News::detail'
        _arguments:
          news-title: news
      - routePath: '/{category-name}'
        _controller: 'News::list'
        _arguments:
          category-name: overwriteDemand/categories
      - routePath: '/{tag-name}'
        _controller: 'News::list'
        _arguments:
          tag-name: overwriteDemand/tags
    defaultController: 'News::list'
    defaults:
      page: '0'
    aspects:
      news-title:
        type: PersistedAliasMapper
        tableName: tx_news_domain_model_news
        routeFieldName: path_segment
      page:
        type: StaticRangeMapper
        start: '1'
        end: '100'
      category-name:
        type: PersistedAliasMapper
        tableName: sys_category
        routeFieldName: slug
      tag-name:
        type: PersistedAliasMapper
        tableName: tx_news_domain_model_tag
        routeFieldName: slug



Am 28.02.2020 um 15:11 schrieb Birgit:

> Hallo Christoph,
>
> kann es sein, dass in deinem YAML eine Einrückung verrutscht ist?
> YAML ist das sehr „empfindlich“.
>
> Das page-0 bekommst du weg, mit dem Setzen von
> defaults:
>       page: '0'
>
>
> viele Grüße Birgit
>
>> Am 28.02.2020 um 14:28 schrieb Christoph <[hidden email]>:
>>
>> Hallo Zusammen,
>>
>> nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
>> schöne URLs zu generieren.
>>
>> Dazu nutze ich den unter
>> https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
>> zu findenden Code.
>>
>> Heraus kommt folgendes:
>>
>> /artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572
>>
>> Das "page-0" kommt von der genannten Konfig.
>>
>> Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
>> doch für die News an sich will es nicht klappen...
>>
>> Hat jemand eine Idee??
>>
>> Danke!
>> VG & schon mal ein schönes Wochenende
>>
>> Christoph
>>
>>
>> _______________________________________________
>> TYPO3-german mailing list
>> [hidden email]
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german


_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: tx_news / Routing

Birgit
Hallo Christoph,

habe gerade das gleiche Phänomen in calendarize.

Das Problem tritt auf, wenn man das Pagination Widget benutzt und von Seite 2 usw. auf die Detailansicht verlinkt.
Das Mapping für das Pagination Widget wird „halb“ mit durchgereicht.

Übrigens auch, wenn man in der Pagination zurück geht auf Seite 1:

/veranstaltungen -> /veranstaltungen/seite-4 -> /veranstaltungen/seite


veranstaltungen/seite-4
Link zur Detailansicht:
veranstaltungen/details//seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5

Arbeite gerade in TYPO3 9.5.14.


viele Grüße Birgit


> Am 28.02.2020 um 16:47 schrieb Christoph <[hidden email]>:
>
> Hallo Birgit,
>
> danke für Deine Antwort!
>
> Ich bin mir sicher, dass ich die Einrückungen richtig habe, sonst würde
> ja auch der part mit "page-0" und die korrekten Tag-Links nicht erzeugt
> werden.
> Unten mal mein Versuch. Ggf. findet noch jemand den Fehler?!
> Danke!
> VG
> Christoph
>
> routeEnhancers:
>   News:
>     type: Extbase
>     limitToPages: [37,1485,136,1486]
>     extension: News
>     plugin: Pi1
>     routes:
>       - routePath: '/'
>         _controller: 'News::list'
>       - routePath: '/page-{page}'
>         _controller: 'News::list'
>         _arguments:
>           page: '@widget_0/currentPage'
>       - routePath: '/{news-title}'
>         _controller: 'News::detail'
>         _arguments:
>           news-title: news
>       - routePath: '/{category-name}'
>         _controller: 'News::list'
>         _arguments:
>           category-name: overwriteDemand/categories
>       - routePath: '/{tag-name}'
>         _controller: 'News::list'
>         _arguments:
>           tag-name: overwriteDemand/tags
>     defaultController: 'News::list'
>     defaults:
>       page: '0'
>     aspects:
>       news-title:
>         type: PersistedAliasMapper
>         tableName: tx_news_domain_model_news
>         routeFieldName: path_segment
>       page:
>         type: StaticRangeMapper
>         start: '1'
>         end: '100'
>       category-name:
>         type: PersistedAliasMapper
>         tableName: sys_category
>         routeFieldName: slug
>       tag-name:
>         type: PersistedAliasMapper
>         tableName: tx_news_domain_model_tag
>         routeFieldName: slug
>
>
>
> Am 28.02.2020 um 15:11 schrieb Birgit:
>> Hallo Christoph,
>>
>> kann es sein, dass in deinem YAML eine Einrückung verrutscht ist?
>> YAML ist das sehr „empfindlich“.
>>
>> Das page-0 bekommst du weg, mit dem Setzen von
>> defaults:
>>      page: '0'
>>
>>
>> viele Grüße Birgit
>>
>>> Am 28.02.2020 um 14:28 schrieb Christoph <[hidden email]>:
>>>
>>> Hallo Zusammen,
>>>
>>> nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
>>> schöne URLs zu generieren.
>>>
>>> Dazu nutze ich den unter
>>> https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
>>> zu findenden Code.
>>>
>>> Heraus kommt folgendes:
>>>
>>> /artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572
>>>
>>> Das "page-0" kommt von der genannten Konfig.
>>>
>>> Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
>>> doch für die News an sich will es nicht klappen...
>>>
>>> Hat jemand eine Idee??
>>>
>>> Danke!
>>> VG & schon mal ein schönes Wochenende
>>>
>>> Christoph
>>>
>>>
>>> _______________________________________________
>>> TYPO3-german mailing list
>>> [hidden email]
>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>> _______________________________________________
>> TYPO3-german mailing list
>> [hidden email]
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>
>
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: tx_news / Routing

Birgit
In reply to this post by Christoph
Korrektur: Es gibt nur einen Slash in der URL vor „Seite“.:

Link zur Detailansicht:
veranstaltungen/details/seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5

> Am 28.02.2020 um 23:59 schrieb Birgit <[hidden email]>:
>
> Hallo Christoph,
>
> habe gerade das gleiche Phänomen in calendarize.
>
> Das Problem tritt auf, wenn man das Pagination Widget benutzt und von Seite 2 usw. auf die Detailansicht verlinkt.
> Das Mapping für das Pagination Widget wird „halb“ mit durchgereicht.
>
> Übrigens auch, wenn man in der Pagination zurück geht auf Seite 1:
>
> /veranstaltungen -> /veranstaltungen/seite-4 -> /veranstaltungen/seite
>
>
> veranstaltungen/seite-4
> Link zur Detailansicht:
> veranstaltungen/details//seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5
>
> Arbeite gerade in TYPO3 9.5.14.
>
>
> viele Grüße Birgit
>
>
>> Am 28.02.2020 um 16:47 schrieb Christoph <[hidden email]>:
>>
>> Hallo Birgit,
>>
>> danke für Deine Antwort!
>>
>> Ich bin mir sicher, dass ich die Einrückungen richtig habe, sonst würde
>> ja auch der part mit "page-0" und die korrekten Tag-Links nicht erzeugt
>> werden.
>> Unten mal mein Versuch. Ggf. findet noch jemand den Fehler?!
>> Danke!
>> VG
>> Christoph
>>
>> routeEnhancers:
>>  News:
>>    type: Extbase
>>    limitToPages: [37,1485,136,1486]
>>    extension: News
>>    plugin: Pi1
>>    routes:
>>      - routePath: '/'
>>        _controller: 'News::list'
>>      - routePath: '/page-{page}'
>>        _controller: 'News::list'
>>        _arguments:
>>          page: '@widget_0/currentPage'
>>      - routePath: '/{news-title}'
>>        _controller: 'News::detail'
>>        _arguments:
>>          news-title: news
>>      - routePath: '/{category-name}'
>>        _controller: 'News::list'
>>        _arguments:
>>          category-name: overwriteDemand/categories
>>      - routePath: '/{tag-name}'
>>        _controller: 'News::list'
>>        _arguments:
>>          tag-name: overwriteDemand/tags
>>    defaultController: 'News::list'
>>    defaults:
>>      page: '0'
>>    aspects:
>>      news-title:
>>        type: PersistedAliasMapper
>>        tableName: tx_news_domain_model_news
>>        routeFieldName: path_segment
>>      page:
>>        type: StaticRangeMapper
>>        start: '1'
>>        end: '100'
>>      category-name:
>>        type: PersistedAliasMapper
>>        tableName: sys_category
>>        routeFieldName: slug
>>      tag-name:
>>        type: PersistedAliasMapper
>>        tableName: tx_news_domain_model_tag
>>        routeFieldName: slug
>>
>>
>>
>> Am 28.02.2020 um 15:11 schrieb Birgit:
>>> Hallo Christoph,
>>>
>>> kann es sein, dass in deinem YAML eine Einrückung verrutscht ist?
>>> YAML ist das sehr „empfindlich“.
>>>
>>> Das page-0 bekommst du weg, mit dem Setzen von
>>> defaults:
>>>     page: '0'
>>>
>>>
>>> viele Grüße Birgit
>>>
>>>> Am 28.02.2020 um 14:28 schrieb Christoph <[hidden email]>:
>>>>
>>>> Hallo Zusammen,
>>>>
>>>> nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
>>>> schöne URLs zu generieren.
>>>>
>>>> Dazu nutze ich den unter
>>>> https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
>>>> zu findenden Code.
>>>>
>>>> Heraus kommt folgendes:
>>>>
>>>> /artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572
>>>>
>>>> Das "page-0" kommt von der genannten Konfig.
>>>>
>>>> Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
>>>> doch für die News an sich will es nicht klappen...
>>>>
>>>> Hat jemand eine Idee??
>>>>
>>>> Danke!
>>>> VG & schon mal ein schönes Wochenende
>>>>
>>>> Christoph
>>>>
>>>>
>>>> _______________________________________________
>>>> TYPO3-german mailing list
>>>> [hidden email]
>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>>> _______________________________________________
>>> TYPO3-german mailing list
>>> [hidden email]
>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>>
>>
>> _______________________________________________
>> TYPO3-german mailing list
>> [hidden email]
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>

_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: tx_news / Routing

Christoph
Hallo Birgitt,

ich habe noch folgende Erkenntnisse:

Wenn ich den defaultController auf "detail" stelle, dann werden mir die
Links zu den Detailansicht korrekt dargestellt, dafür dann die Links
beim Tagfilter nicht mehr...

Wenn ich bei

     - routePath: '/{news-title}'
       _controller: 'News::detail'
       _arguments:

das "detail" auf "list" stelle, passen die URLs auch, aber irgendwie
scheint das nicht richtig zu sein.
Werd das noch mal in einer anderen Installation testen..

VG
Christoph

Am 29.02.2020 um 00:05 schrieb Birgit:

> Korrektur: Es gibt nur einen Slash in der URL vor „Seite“.:
>
> Link zur Detailansicht:
> veranstaltungen/details/seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5
>
>> Am 28.02.2020 um 23:59 schrieb Birgit <[hidden email]>:
>>
>> Hallo Christoph,
>>
>> habe gerade das gleiche Phänomen in calendarize.
>>
>> Das Problem tritt auf, wenn man das Pagination Widget benutzt und von Seite 2 usw. auf die Detailansicht verlinkt.
>> Das Mapping für das Pagination Widget wird „halb“ mit durchgereicht.
>>
>> Übrigens auch, wenn man in der Pagination zurück geht auf Seite 1:
>>
>> /veranstaltungen -> /veranstaltungen/seite-4 -> /veranstaltungen/seite
>>
>>
>> veranstaltungen/seite-4
>> Link zur Detailansicht:
>> veranstaltungen/details//seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5
>>
>> Arbeite gerade in TYPO3 9.5.14.
>>
>>
>> viele Grüße Birgit
>>
>>
>>> Am 28.02.2020 um 16:47 schrieb Christoph <[hidden email]>:
>>>
>>> Hallo Birgit,
>>>
>>> danke für Deine Antwort!
>>>
>>> Ich bin mir sicher, dass ich die Einrückungen richtig habe, sonst würde
>>> ja auch der part mit "page-0" und die korrekten Tag-Links nicht erzeugt
>>> werden.
>>> Unten mal mein Versuch. Ggf. findet noch jemand den Fehler?!
>>> Danke!
>>> VG
>>> Christoph
>>>
>>> routeEnhancers:
>>>  News:
>>>    type: Extbase
>>>    limitToPages: [37,1485,136,1486]
>>>    extension: News
>>>    plugin: Pi1
>>>    routes:
>>>      - routePath: '/'
>>>        _controller: 'News::list'
>>>      - routePath: '/page-{page}'
>>>        _controller: 'News::list'
>>>        _arguments:
>>>          page: '@widget_0/currentPage'
>>>      - routePath: '/{news-title}'
>>>        _controller: 'News::detail'
>>>        _arguments:
>>>          news-title: news
>>>      - routePath: '/{category-name}'
>>>        _controller: 'News::list'
>>>        _arguments:
>>>          category-name: overwriteDemand/categories
>>>      - routePath: '/{tag-name}'
>>>        _controller: 'News::list'
>>>        _arguments:
>>>          tag-name: overwriteDemand/tags
>>>    defaultController: 'News::list'
>>>    defaults:
>>>      page: '0'
>>>    aspects:
>>>      news-title:
>>>        type: PersistedAliasMapper
>>>        tableName: tx_news_domain_model_news
>>>        routeFieldName: path_segment
>>>      page:
>>>        type: StaticRangeMapper
>>>        start: '1'
>>>        end: '100'
>>>      category-name:
>>>        type: PersistedAliasMapper
>>>        tableName: sys_category
>>>        routeFieldName: slug
>>>      tag-name:
>>>        type: PersistedAliasMapper
>>>        tableName: tx_news_domain_model_tag
>>>        routeFieldName: slug
>>>
>>>
>>>
>>> Am 28.02.2020 um 15:11 schrieb Birgit:
>>>> Hallo Christoph,
>>>>
>>>> kann es sein, dass in deinem YAML eine Einrückung verrutscht ist?
>>>> YAML ist das sehr „empfindlich“.
>>>>
>>>> Das page-0 bekommst du weg, mit dem Setzen von
>>>> defaults:
>>>>     page: '0'
>>>>
>>>>
>>>> viele Grüße Birgit
>>>>
>>>>> Am 28.02.2020 um 14:28 schrieb Christoph <[hidden email]>:
>>>>>
>>>>> Hallo Zusammen,
>>>>>
>>>>> nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
>>>>> schöne URLs zu generieren.
>>>>>
>>>>> Dazu nutze ich den unter
>>>>> https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
>>>>> zu findenden Code.
>>>>>
>>>>> Heraus kommt folgendes:
>>>>>
>>>>> /artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572
>>>>>
>>>>> Das "page-0" kommt von der genannten Konfig.
>>>>>
>>>>> Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
>>>>> doch für die News an sich will es nicht klappen...
>>>>>
>>>>> Hat jemand eine Idee??
>>>>>
>>>>> Danke!
>>>>> VG & schon mal ein schönes Wochenende
>>>>>
>>>>> Christoph
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> TYPO3-german mailing list
>>>>> [hidden email]
>>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>>>> _______________________________________________
>>>> TYPO3-german mailing list
>>>> [hidden email]
>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>>>
>>> _______________________________________________
>>> TYPO3-german mailing list
>>> [hidden email]
>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german


_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
Reply | Threaded
Open this post in threaded view
|

Re: tx_news / Routing

Christoph
Abend Zusammen,

Problem gefunden, es lag an folgender Konfiguration:

plugin.tx_news.settings.link.skipControllerAndAction = 1

Das war noch aus irgendwelchen historischen Gründen drinnen..
VG & gute Nacht!
Christoph



Am 29.02.2020 um 10:30 schrieb Christoph:

> Hallo Birgitt,
>
> ich habe noch folgende Erkenntnisse:
>
> Wenn ich den defaultController auf "detail" stelle, dann werden mir die
> Links zu den Detailansicht korrekt dargestellt, dafür dann die Links
> beim Tagfilter nicht mehr...
>
> Wenn ich bei
>
>      - routePath: '/{news-title}'
>        _controller: 'News::detail'
>        _arguments:
>
> das "detail" auf "list" stelle, passen die URLs auch, aber irgendwie
> scheint das nicht richtig zu sein.
> Werd das noch mal in einer anderen Installation testen..
>
> VG
> Christoph
>
> Am 29.02.2020 um 00:05 schrieb Birgit:
>> Korrektur: Es gibt nur einen Slash in der URL vor „Seite“.:
>>
>> Link zur Detailansicht:
>> veranstaltungen/details/seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5
>>
>>> Am 28.02.2020 um 23:59 schrieb Birgit <[hidden email]>:
>>>
>>> Hallo Christoph,
>>>
>>> habe gerade das gleiche Phänomen in calendarize.
>>>
>>> Das Problem tritt auf, wenn man das Pagination Widget benutzt und von Seite 2 usw. auf die Detailansicht verlinkt.
>>> Das Mapping für das Pagination Widget wird „halb“ mit durchgereicht.
>>>
>>> Übrigens auch, wenn man in der Pagination zurück geht auf Seite 1:
>>>
>>> /veranstaltungen -> /veranstaltungen/seite-4 -> /veranstaltungen/seite
>>>
>>>
>>> veranstaltungen/seite-4
>>> Link zur Detailansicht:
>>> veranstaltungen/details//seite?tx_calendarize_calendar[index]=76&cHash=bce76310fdb2119ee4f3176b46ec2ac5
>>>
>>> Arbeite gerade in TYPO3 9.5.14.
>>>
>>>
>>> viele Grüße Birgit
>>>
>>>
>>>> Am 28.02.2020 um 16:47 schrieb Christoph <[hidden email]>:
>>>>
>>>> Hallo Birgit,
>>>>
>>>> danke für Deine Antwort!
>>>>
>>>> Ich bin mir sicher, dass ich die Einrückungen richtig habe, sonst würde
>>>> ja auch der part mit "page-0" und die korrekten Tag-Links nicht erzeugt
>>>> werden.
>>>> Unten mal mein Versuch. Ggf. findet noch jemand den Fehler?!
>>>> Danke!
>>>> VG
>>>> Christoph
>>>>
>>>> routeEnhancers:
>>>>  News:
>>>>    type: Extbase
>>>>    limitToPages: [37,1485,136,1486]
>>>>    extension: News
>>>>    plugin: Pi1
>>>>    routes:
>>>>      - routePath: '/'
>>>>        _controller: 'News::list'
>>>>      - routePath: '/page-{page}'
>>>>        _controller: 'News::list'
>>>>        _arguments:
>>>>          page: '@widget_0/currentPage'
>>>>      - routePath: '/{news-title}'
>>>>        _controller: 'News::detail'
>>>>        _arguments:
>>>>          news-title: news
>>>>      - routePath: '/{category-name}'
>>>>        _controller: 'News::list'
>>>>        _arguments:
>>>>          category-name: overwriteDemand/categories
>>>>      - routePath: '/{tag-name}'
>>>>        _controller: 'News::list'
>>>>        _arguments:
>>>>          tag-name: overwriteDemand/tags
>>>>    defaultController: 'News::list'
>>>>    defaults:
>>>>      page: '0'
>>>>    aspects:
>>>>      news-title:
>>>>        type: PersistedAliasMapper
>>>>        tableName: tx_news_domain_model_news
>>>>        routeFieldName: path_segment
>>>>      page:
>>>>        type: StaticRangeMapper
>>>>        start: '1'
>>>>        end: '100'
>>>>      category-name:
>>>>        type: PersistedAliasMapper
>>>>        tableName: sys_category
>>>>        routeFieldName: slug
>>>>      tag-name:
>>>>        type: PersistedAliasMapper
>>>>        tableName: tx_news_domain_model_tag
>>>>        routeFieldName: slug
>>>>
>>>>
>>>>
>>>> Am 28.02.2020 um 15:11 schrieb Birgit:
>>>>> Hallo Christoph,
>>>>>
>>>>> kann es sein, dass in deinem YAML eine Einrückung verrutscht ist?
>>>>> YAML ist das sehr „empfindlich“.
>>>>>
>>>>> Das page-0 bekommst du weg, mit dem Setzen von
>>>>> defaults:
>>>>>     page: '0'
>>>>>
>>>>>
>>>>> viele Grüße Birgit
>>>>>
>>>>>> Am 28.02.2020 um 14:28 schrieb Christoph <[hidden email]>:
>>>>>>
>>>>>> Hallo Zusammen,
>>>>>>
>>>>>> nach einem Update von TYPO3 8 auf 9 versuche ich gerade für tx_news
>>>>>> schöne URLs zu generieren.
>>>>>>
>>>>>> Dazu nutze ich den unter
>>>>>> https://docs.typo3.org/p/georgringer/news/master/en-us/AdministratorManual/BestPractice/Routing/Index.html#basic-setup-including-categories-and-tags
>>>>>> zu findenden Code.
>>>>>>
>>>>>> Heraus kommt folgendes:
>>>>>>
>>>>>> /artikel-1/page-0/?tx_news_pi1%5Bnews%5D=147&cHash=d618f904c86364f5ec130052ba0c4572
>>>>>>
>>>>>> Das "page-0" kommt von der genannten Konfig.
>>>>>>
>>>>>> Ein auf der Seite eingefügter "tagfilter" erzeugt ebenfalls schöne URls,
>>>>>> doch für die News an sich will es nicht klappen...
>>>>>>
>>>>>> Hat jemand eine Idee??
>>>>>>
>>>>>> Danke!
>>>>>> VG & schon mal ein schönes Wochenende
>>>>>>
>>>>>> Christoph
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> TYPO3-german mailing list
>>>>>> [hidden email]
>>>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>>>>> _______________________________________________
>>>>> TYPO3-german mailing list
>>>>> [hidden email]
>>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>>>> _______________________________________________
>>>> TYPO3-german mailing list
>>>> [hidden email]
>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>> _______________________________________________
>> TYPO3-german mailing list
>> [hidden email]
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
>
> _______________________________________________
> TYPO3-german mailing list
> [hidden email]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german


_______________________________________________
TYPO3-german mailing list
[hidden email]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german